#110 new
Georg Huber

tvnamer / tvdb

Reported by Georg Huber | October 1st, 2017 @ 09:14 AM

I installed tvdb_api v2 via the FreeBSD ports management pkg. No install problems. However tvnamer now always quits with:

root@FreeBSD:/usr/local/lib/python2.7/site-packages/tvnamer # tvnamer .
Traceback (most recent call last):
File "/usr/local/bin/tvnamer", line 6, in from pkg_resources import load_entry_point File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3038, in @_call_aside File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3022, in call_aside f(*args, **kwargs) File "/usr/local/lib/python2.7/site-packages/pkg_resources/_init__.py", line 3051, in initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/local/lib/python2.7/site-packages/pkg_resources/_init__.py", line 657, in build_master ws.require(_requires__) File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 971, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 857, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'requests' distribution was not found and is required by tvdb-api

Unfortunately I don't "speak" Python so I don't understand a word of what he's saying.

Anyone has a clue what went wrong?

PS: I did re-install tvnamer after installing tvdb.api 2.0

Thanks for the help

Comments and changes to this ticket

  • dbr/Ben

    dbr/Ben October 3rd, 2017 @ 10:31 AM

    I'm not sure how the FreeBSD ports system deals with Python packages - but the error is caused by the "requests" Python module dependency not being installed.

    You could probably work around this by installing it manually, but I guess "something" needs updated so this happens automatically (the port thing was probably setup ages ago before tvdb_api required requests)

  • Georg Huber

    Georg Huber October 4th, 2017 @ 06:16 PM

    Thanks!

    I installed the resources port now it requests resources_cache which I cannot find in the FreeBSD port tree.

    I guess you are right that "something" needs update!

    Thanks again

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

People watching this ticket

Pages